On p 180 of 2.0, the dealloc method is defined thus.
Should it not be this?
I think there might also be a misquote on the same page.
"The dealloc method is defined to return a value of type id. You know this by looking inside the header file <NSObject.h>.....
NSObject.h shows this though....
- (void)dealloc;
Thanks in advance.
Code:
-(id) dealloc
{
if (origin)
[origin release];
return [super dealloc];
}
Should it not be this?
Code:
-(void) dealloc
{
if (origin)
[origin release];
[super dealloc];
}
I think there might also be a misquote on the same page.
"The dealloc method is defined to return a value of type id. You know this by looking inside the header file <NSObject.h>.....
NSObject.h shows this though....
- (void)dealloc;
Thanks in advance.